Seite 62 von 62 ErsteErste ... 12525859606162
Ergebnis 1.221 bis 1.240 von 1240

Thema: RPG2000 und 2003-Sammelthread für Probleme

  1. #1221
    Vreeky kommt gefliecht um wieder zu helfen~ =D


    Die "Berge" und Bäume, und alles im Screen markierte, sind Auto-Tiles, und wenn du die passend überlappen willst, dann musst du ein wenig tricksen. Machs mal so: Halte SHIFT gedrückt und wähle mit dem rechten Mausknopf die bereits gesetzten Bäume am Maprand aus ... wenn du die jetzt (weiterhin SHIFT gedrückt halten) auf die Klippen/Berge setzt wirst du was tolles bemerken. Es ist leider etwas umständlich, aber teste mal ein bissl damit rum, und vllt kommst du dann von selber dahinter wie das Map-System funktioniert.

    Ich empfehle dir die Klippen weiter unten in der Tile-Auswahl (Tab A) zu nutzen! Die musst du zwar selber zusammenpuzzl'n, aber so kannst du da ohne Probleme Auto-Tiles und andere Sachen drüberpflastern.

    PS: Korken und Ich schreiben hier einfach weiter ... bis IRGENDWER den Thread-Titel in "Allgemeine RPG-Maker-Fragen" oder so ändert! Höhö.

    Geändert von Vreeky (20.02.2017 um 12:53 Uhr)

  2. #1222
    Von mir mal ne Frage: In den letzten Jahren sind ja mehr und mehr Probleme aufgetaucht, 2k/3-Spiele auf heutigen Systemen zu spielen, ohne dabei irgendwelche Zusatzsoftware zu benötigen, die Späße wie den kaputten Fullscreen-Mode ausbügelt. Ist das auch bei der Steam-Version der Fall oder läuft die vernünftig?

    Ich spiele wieder mit dem Gedanken, mein (oder zumindest ein Nebenprojekt, kA) Projekt doch auf dem 2k3 anzufangen, da ich damit halt vertraut bin, aber ich hab da wirklich keine Lust drauf, wenn die Probleme dann schon auf dem Level anfangen.

  3. #1223
    Hallo liebes Forum,

    ich hatte bei meinem letzten Spiel ein Grafikproblem, welches ich nicht beheben konnte. Ich wollte einzelne Charsets in Monster umwandeln. Das sah vorerst auch normal aus, als ich es jedoch importiert habe, so das der Maker 2000 es erkennen konnte, gab es Farbfehler.

    Mir wurde erklärt, dass es mit den 256 Farben zusammenhängen könnte, jedoch hat das selbe Prinzip bei Charsets für BattleAnimations funktioniert UND bei Chipsets als BattleBackground. Dazu kommt, dass die Figuren teilweise sehr wenig farbe hatten. Unter anderem nur grau.

    Und selbst da gab es Fehler. ich verstehe nicht woran es liegt.

    Weiß vielleicht jemand eine Lösung, die ich übersehen habe?

    Grüße

    Amano

  4. #1224
    Mit manchen Farbkonstellationen haben die alten Maker anscheinend ziemliche Probleme. Als ich für mein Spiel einen neuen Textboxhintergrund erstellt habe, hat mir der Maker aus einem Marmormuster Pixelmatsch gemacht, obwohl ich deutlich unter 256 Farben geblieben bin. Ich hab das Problem dadurch gelöst, in dem ich den Farbkontrast zw. Marmorierung und Basisfarbe erhöht habe. Da ich die Charsets nicht kenne, kann ich nicht sagen, ob ein stärkerer Kontrast auch bei deinem Problem hilft. Sollte dir dieser Hinweis also nichts bringen, dann poste doch mal hier ein Vorher- und Nachherbild. Dann lässt sich bestimmt Genaueres sagen.

  5. #1225
    Die alten Maker können nur die 16-bit-Farbpalette nutzen, während die Grafikprogramme auf 24 bit zurückgreifen. Für alle Farben, die der Maker nicht anzeigen kann, nimmt er dann die nächstbeste Farbe, die auf der Palette ist.

  6. #1226
    @Leana: Danke für den Tipp.

    @Kelven: Was müsste ich also konkret tun? Ich nutze übrigens Paint.NET zur Bearbeitung.

  7. #1227
    Mehr als die Farben händisch anzupassen fällt mir leider nicht ein. Ich weiß auch nicht, wie man erkennt, welche Farbe zu welcher Palette gehört.

  8. #1228
    Eben genau das ist das Problem. Die Farbfehler entstehen in der Umwandlung. Es ist so: ich habe ein Charset, ich mache eine Pose, schneide diese aus, packe sie zu den Monstern und wandle sie dann durch exportieren um in ein Monster.
    Es werden also keine Farben geändert, sondern Charset-akurate Farben werden übernommen, nur um dann fehlerhaft dargestellt zu werden.

  9. #1229
    Am besten, du postest mal den Charset und das Monsterbild als Beispiel. Vielleicht lässt sich dann erkennen, woher die Fehler kommen.

  10. #1230
    Es ist echt nicht nachzuvollziehen was du hier genau machst.

  11. #1231
    Sagt mal, weil ich gerade an was um der guten alten Zeit Willen skripte und es nach den ganzen Jahren einfach nicht mehr weiß:

    Rundet der Maker auf oder ab bzw. ab wo? Sprich, würde bei 12/10 und 17/10 das selbe rauskommen (wenn ja: 1 oder 2?) oder würde der Maker da differenzieren? Ich umschiffe das Thema jetzt mit Hilfe von Modulo, aber so mal aus reiner Neugier.

  12. #1232
    Wenn ich das richtig in Erinnerung habe, wird gar nicht gerundet, er schneidet einfach die Nachkommastellen ab.

  13. #1233
    Ja, so hatte ich das auch im Kopf. Aber gut, dann ist immerhin ohne zusätzliche Abfragen absehbar, was rauskommt xD
    Dankesehr~

  14. #1234
    wenn es um Prozentrechnung geht, umschiffe ich das zB ganz gerne, indem ich erst multipliziere und dann dividiere.

  15. #1235
    Ne, ich habe (bzw. hatte) eine Variable, die mehrere Werte (bspw. a, b, c und d, alle maximal zweistellig) gleichzeitig enthält, gespeichert in verschiedenen Ziffern: aabbccdd

    Wenn du nun an den Wert c möchtest, kannst du mit Mod 10'000 die ersten 4 Ziffern und dann mit /100 die letzten beiden abschneiden, übrig bleibt dann c (bzw. cc). Würde der Maker aber runden, gäbe es da u.U. Probleme, da sich die Werte dann plötzlich beim Auslesen potenziell gegenseitig verfälschen könnten.

    Das ganze lohnt sich eigentlich nur, wenn man seeeehr lange Listen an Variablen braucht und sparen möchte oder Werte hat, die zusammengehören und die man auch zusammen gespeichert haben will und ist eher eine dieser Holzhammermethoden.

  16. #1236
    @Kelven
    Hi, sorry für die späte Antwort.
    Hier einmal eine kurze Auffrischung der Frage: Ich habe Charsets in Monstersets umwandeln wollen. Alles war soweit gut, doch sobald ich die Grafiken importiere, so dass der Rm2000 sie als Monstergrafiken anerkennt, ändert sich die Farbe.
    Selbst Graustufen bei den Wölfen haben sich verändert. Ich weiß nicht woran es liegt. Die Bilder sind im 256 Farben Bereich UND werden als Charsets ja auch anerkannt.
    Hier sind zwei Beispielbilder. Die Gegner als Charsets Klicke auf die Grafik für eine größere Ansicht 

Name:	Gegner.png 
Hits:	7 
Größe:	12,3 KB 
ID:	24279 Klicke auf die Grafik für eine größere Ansicht 

Name:	wolf2.png 
Hits:	6 
Größe:	8,7 KB 
ID:	24280
    Und hier nochmal die Gegner als Mosnterset. Klicke auf die Grafik für eine größere Ansicht 

Name:	Räuber_Schwert.png 
Hits:	70 
Größe:	1,0 KB 
ID:	24281 Klicke auf die Grafik für eine größere Ansicht 

Name:	wolf_alpha.png 
Hits:	70 
Größe:	1,0 KB 
ID:	24277 Klicke auf die Grafik für eine größere Ansicht 

Name:	Wilder_Schwert.png 
Hits:	72 
Größe:	1,1 KB 
ID:	24278

    Die Farben sind zwar minimal anders, aber es fällt dennoch auf. Wie kann ich so ein Problem beheben?

    Mfg

    Amano

    Geändert von Amano (22.08.2017 um 14:22 Uhr)

  17. #1237
    Eine andere Frage wäre, ob man beim Rm2000 direkt das Item Menü öffnen kann und wenn ja, wo ich diesen Befehl finde?

  18. #1238
    Zitat Zitat von Amano Beitrag anzeigen
    Eine andere Frage wäre, ob man beim Rm2000 direkt das Item Menü öffnen kann und wenn ja, wo ich diesen Befehl finde?
    Von Haus aus gibt es leider keinen Befehl dafür.

  19. #1239
    Schade. Danke für die schnelle Antwort.

  20. #1240
    Man kann sich aber auch glaube ich ein eigenes Item Menü zusammen basteln das sollte auch gehen und wenn es einem das Wert ist dann würde ich da auch die Arbeit knallhart rein investieren damit es dem Spieler auch maximal zusagt. Tutorials findest du bestimmt hier auch im rpg Atelier.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •